





CHAPTER ONE

Introduction







WELCOME! IF YOU’RE interested in learning how to develop Mac apps in Swift, you’ve come to the right place. Swift Dev Journal’s Intro to Cocoa will guide you through the process of making a working Mac app without boring you with hundreds of pages of theory.










What You Need





To use this book you need the following:






	A Mac running a relatively recent version of macOS

	Xcode installed on the Mac

	Some knowledge of Swift







I wrote the code for this book in Xcode 10 using Swift 5 and tested the code on Xcode 11. That means anyone running Xcode 10 and higher on macOS 10.13 and higher should be able to use the code in this book with no changes. I have not tested on earlier systems, but the code should run on Xcode 9, macOS 10.12, and Swift 4 with minor changes.





You can download the latest version of Xcode from the Mac App Store. If your Mac is incapable of running the latest Xcode, you can download Xcode from Apple’s developer site (developer.apple.com) or from the site Xcode Releases (xcodereleases.com).





This book does not teach the Swift language so you need some familiarity with Swift. The code in the book does not use complicated Swift features like generics, functional programming, and operator overloading so you don’t need to be a Swift expert to use this book.










The Parts of a Mac App





A Mac GUI app has the following parts:






	User interface

	Model

	Input/Output






User Interface





The user interface is the part of the app people see as they use the app. A good user interface makes a Mac app feel like a Mac app. A Mac app’s user interface usually has the following components:






	A menu bar and menus

	One or more windows

	Views and controls







The menu bar and its menus distinguish a Mac app from an iOS app. The menus contain a list of items for people to choose from. Creating a menu bar and menus may sound difficult, but when you create a Cocoa application project in Xcode, the storyboard or xib file contains a menu bar with the standard menus and menu items. Normally you only have to add menus and menu items specific to your app.





Mac apps have one or more windows. A window has controls to resize, minimize, and close the window. You can also move windows by clicking at the top of window and dragging them. The Cocoa framework provides this standard behavior for you.





Windows contain views and controls. The views and controls you’ll use depend on your app, but some common views and controls are buttons, text fields, and table views.




Model





The model for an app is the app’s data. Each app has its own specific model. The model for Apple’s Photos app is photos. The model for the Mail app is email messages. The model for a text editor is text documents and the contents of the documents.




Input/Output





Mac apps accept input and generate output. Examples of accepting input include people entering data with the keyboard, downloading data from the Internet, and opening files. Examples of generating output include saving files and printing.










The App You’ll Create





As you go through this book, you will apply the concepts by creating a Mac app called NoteTaker. The name NoteTaker indicates that it’s a note-taking app. A note-taking app shows off many common Mac app features and concepts while being simple enough to keep from overwhelming you.





If you think a note-taking app is too simple, look at the following list of things a note-taking app needs:






	A data structure to store a note

	A way to store a list of notes

	A view to display the list of notes

	A view to enter notes

	A control to add notes

	A control to remove notes

	Saving notes so you don’t lose them when you quit the app

	Loading the notes when the app launches







And that’s just a basic list of needs. You might feel overwhelmed by all you need to do to make a simple Mac app. But you’re going to build the app one piece at a time until you have a working app.





I have the project available for you to download on GitHub (https://github.com/SwiftDevJournal/NoteTaker) in case you run into problems. There are branches for various chapters so you can see how I created the app piece by piece.










Book Contents





Each chapter in the book takes you one step closer to a finished Mac app.




Create the Project





You’ll take the first step of your Mac programming journey in Chapter 2. You will create the NoteTaker Xcode project and learn the basics of Xcode.




Build the User Interface





Over the next four chapters you’ll build NoteTaker’s user interface. Chapter 3 provides an introduction to storyboards and explains common user interface building tasks.





In Chapter 4 you’ll create the user interface for the notes window. In Chapter 5 you’ll add a toolbar so people can easily add and remove notes. In Chapter 6 you’ll learn about menus by adding a Notes menu to the menu bar.




Code the Foundation





The next four chapters build the foundation of the NoteTaker app in code. In Chapter 7 you’ll create view controller subclasses and learn about view controllers. 





In Chapter 8 you’ll create the data model by creating a data structure for a note and creating a list of notes.





In Chapter 9 you’ll learn how to display the list of notes in a table view. In Chapter 10 you’ll learn the basics of working with text views.




Working with Notes





The next four chapters make the NoteTaker app usable. In Chapter 11 you’ll learn how to add new notes. In Chapter 12 you’ll learn how to change a note’s title. In Chapter 13 you’ll learn how to remove notes.





Chapter 14 teaches notifications. You’ll learn how to deal with table view selection changes and changes to the text in the text view.




Working with Files





In Chapter 15 you’ll learn how to save the notes to disk and load them when the app launches. When you finish Chapter 15, you’ll have a working app.




Improving the App





The final three chapters make improvements to the NoteTaker app. In Chapter 16 you’ll learn about timers by adding autosave support. In Chapter 17 you’ll learn how to undo note deletion in case someone accidentally removes a note. The last chapter makes smaller, miscellaneous improvements to the NoteTaker app.










Some Things to Keep in Mind





This book is an introduction to Cocoa. It’s not a comprehensive guide to Cocoa. I’m not going to be able to cover everything about making Mac apps in one book.





The NoteTaker app is a demonstration of various Cocoa technologies. It’s not meant to be a replacement for the various note taking apps available on Mac and iOS.





There can be multiple ways to solve a problem. You may find a better way to code something than what I used in the book. If you find a better way, go with it.













CHAPTER TWO

Create the Project







THE FIRST STEP to creating a Mac app is to create a project in Xcode. Choose File > New > Project in Xcode to open the New Project Assistant.
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Select macOS from the top of the New Project Assistant to see the available Mac projects. Select the Cocoa App (App in Xcode 11) project and click the Next button to move on to the second step.
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Enter the name of the project in the Product Name text field.





Choose None from the Team menu unless you have a paid Apple developer account.





Enter an organization name in the Organization Name text field. Enter your name if you don’t belong to an organization.





Enter the organization identifier in the Organization Identifier text field. An organization identifier takes the following form:





com.OrganizationName






Make sure there are no spaces in the identifier.





Choose Swift from the Language menu.





Choose Storyboard from the User Interface menu. If you’re running Xcode 10 or earlier, select the Use Storyboards checkbox.





Deselect the Create Document-Based Application and Use Core Data checkboxes.





Whether or not you select the Include Unit Tests and Include UI Tests checkbox is a matter of personal preference. I will not be doing any unit testing or UI testing in this book.





Click the Next button to move on the final step. Choose a location to save your project and click the Create button to finish creating the project.





You will see the following at the bottom of the Save panel:
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If you select the Create Git repository checkbox, Xcode will place your project under version control. Placing your project under version control is a matter of personal preference.










Project Files





After creating the project a project window opens in Xcode. On the left side of the project window is the project navigator, which shows the files in the project.
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If you deselected the checkboxes to include unit tests and UI tests when you created the project, there won’t be folders for the tests and UI tests in the project navigator and items for the tests in the Products folder. 





You should see the following files in the project navigator:






	AppDelegate.swift

	ViewController.swift

	Assets.xcassets

	Main.storyboard

	Info.plist

	ProjectName.entitlements







The storyboard file is the file you’ll end up viewing and editing the most in this book, but it’s important to know about the other files.




AppDelegate





The AppDelegate.swift file lets you add code to run when your app launches and terminates.




ViewController





The ViewController.swift file contains a class file for the view controller Xcode creates in the storyboard. A view controller manages a view. You will create a view controller class for every view controller you add to the storyboard.





For the project in this book, you’re going to remove the ViewController.swift file. When you build the user interface, you’re going to add a split view controller to the storyboard. The split view controller comes with its own view controllers so you won’t need the one Xcode creates for you. But if you’re creating a Mac app that needs only a single view controller, you can use ViewController.swift for the view controller.




Assets Folder





The Assets folder contains the images in your project. The most common use of the Assets folder is to add an icon for your app.




Storyboard





The storyboard contains your app’s user interface. Select the storyboard to open it and build your app’s user interface.




Info.plist





The Info.plist file contains information about your app, such as the version number and a copyright notice.





While you can edit the Info.plist file directly, it’s usually easier to use Xcode’s project editor. Select the project from the project navigator to open the project editor. Select the app target from the left side of the project editor. Click the Info button at the top of the project editor to start editing Info.plist.
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Entitlements File





The entitlements file contains a list of Apple technology capabilities that your app supports, such as iCloud and in-app purchases. If you select the entitlements file, you will notice that the App Sandbox is turned on.





While you can add and remove capabilities from the entitlements file, it’s usually easier to do it from Xcode’s project editor. Select the app target from the left side of the project editor. Click the Capabilities button at the top of the project editor.
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If you want your app to support things like iCloud and push notifications, turn the switch from Off to On. Most of the capabilities require your app to be code signed, which means you have to be a paid member of Apple’s developer program to use them.





In Xcode 11, the button at the top of the project editor is called Signing & Capabilities.
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You’ll also notice in Xcode 11 that the project editor shows only the active capabilities. Click the Add Capability button to add support for things like iCloud and push notifications. Click the X button to remove a capability.





Turn off the App Sandbox. It will mess things up when saving the notes to disk.










Make the App Run on Older macOS Versions





When you create a Cocoa application project, Xcode sets the deployment target to the version of macOS your Mac is running. The deployment target is the earliest version of macOS that can run the project. Unless you change the deployment target, your app won’t run on Macs running an older version of macOS.





To change the deployment target, select the project from the project navigator to open the project editor. Select the project from the left side of the project editor.
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Choose an operating system version from the macOS Deployment Target combo box. The app being built in this book can run on macOS 10.11 and higher so you can set the deployment target to 10.11 if you want.





Keep in mind that setting the deployment target isn’t sufficient to support earlier macOS versions. You have to make sure not to use newer technologies that were introduced after the deployment target. Suppose you want to develop a Mac app with SwiftUI. Apple introduced SwiftUI in macOS 10.15. Mac apps built with SwiftUI won’t run on anything earlier than 10.15. Setting the deployment target to macOS 10.12 isn’t going to magically make your SwiftUI app run on 10.12.










Run the Project





If you want you can build and run the project by clicking the Play button in the toolbar or choosing Product > Run. The app should show a blank window.













CHAPTER THREE

Intro to Storyboards and Related Tools







IN LATER CHAPTERS you are going to spend lots of time working with storyboards and Interface Builder (a tool bundled with Xcode) to build the app’s user interface. To keep from repeating the same information constantly in those chapters, I’m writing this chapter, which you can use as a reference to go back to if you’re confused by some instructions.




Storyboard Components





A storyboard has the following areas:






	Jump bar

	Document outline

	Canvas
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The jump bar and document outline provide alternative ways to access the items in the storyboard. The jump bar organizes the items hierarchically. The jump bar takes less space but doesn’t show as much information. The document outline shows more items at once but takes up more screen space. There’s a button below the canvas to toggle the document outline so you can hide it when you don’t need to access it.





The canvas contains the user interface: windows, view controllers, menus, and so on.




Object Library





The Object Library contains the user interface elements you can add to your apps. The Object Library is not intuitive to find. The button to open the Object Library is the leftmost button in the groups of buttons on the right side of the project window toolbar.




[image: ]





Option-clicking the Object Library button keeps the Object Library open, which helps when you’re initially laying out the interface. Having to constantly open the Object Library gets annoying after a while.
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Mac apps have lots of user interface elements. You can narrow things down by entering a search term in the search field at the top of the window.




Laying out the Interface





You lay out the user interface by dragging an item from the Object Library to the canvas. View controllers and windows can be dragged directly to the canvas. Views and controls generally are dragged to view controllers.




Selecting an Item





Click on an item in the canvas to select it.
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If a view is nested in a hierarchy, such as a view inside a scroll view, it can be easier to select the item using the jump bar or document outline.




Moving an Item





Select the item and drag it to move it to a new position.




Resizing an Item





Select the item. Click on one of the eight squares on the edge of the selected item and drag to resize the item.




Changing an Item’s Title





To change an item’s title, double-click the text and enter the new title.










Inspectors





Use the inspectors to make adjustments to user interface elements that are more complicated than moving or resizing. The inspectors are on the right side of the project window. Mac projects have the following inspectors:






	File

	History (added in Xcode 11)

	Quick Help

	Identity

	Attributes

	Size

	Connections

	Bindings

	View Effects







The inspectors you will use in this book are the identity, attributes, size, and connections inspectors.




Identity Inspector





The main use of the identity inspector is to set a user interface element’s class. If you subclass a view controller or another user interface element, you must set the element’s class to tell Xcode that the UI element is an object of your subclass.




Attributes Inspector





The attributes inspector is where you view and edit a user interface element’s attributes. What you can edit depends on the element.




Size Inspector





The size inspector allows you to set an element’s position and size. You can also control how the element reacts when someone resizes the window.




Connections Inspector





The connections inspector lists an element’s available outlets and actions and shows which ones are connected.










Outlets and Actions





Outlets and actions allow your code to work with user interface elements in storyboards.





An outlet is a variable that holds a reference to an item in a storyboard or xib file. Use outlets to access UI elements in your code. The following code shows an example of an outlet:





@IBOutlet var textView: NSTextView!






The @IBOutlet specifies that the variable is an outlet.





An action is a function that is called when someone interacts with a user interface element, such as clicking a button or choosing an item from a menu. The following code shows an example of an action:





@IBAction func addNote(_ sender: AnyObject) {

}






The @IBAction at the start marks the function as an action. Actions take one argument, the sender of the action. Normally the type of the sender argument is AnyObject, but it can also be the type of the user interface element. If your app performs an action when someone clicks a button, you can make the type of the sender argument NSButton, which is the class for buttons in Mac apps.










Making Connections





Making connections is the way you hook up user interface elements to other elements and to the outlets and actions you create in code. To make a connection between two items in a storyboard, select the first item, hold down the Control key, and drag to the second item.




Opening Editors for the Storyboard and Source Code File





If you want to make a connection from the storyboard to a source code file, you must have the storyboard and source code file open in separate editors. Once you have two editors open, use the jump bar at the top of each editor to open the storyboard and source code file.





Xcode 11 changed the way you open editors so I have separate instructions for Xcode 11 and earlier versions.




Xcode 11 and Later





Xcode 11 simplifies opening editors. Choose File > New > Editor to add an editor to the project window. You can also click the Add Editor button in the jump bar.
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Xcode 10 and Earlier





To have multiple editors open in earlier versions of Xcode, you must switch to the Assistant Editor. Choose View > Assistant Editor > Show Assistant Editor to open the Assistant Editor.





You can also click the Assistant Editor button in the project window toolbar.
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The Assistant Editor button is the button with the dark background in the screenshot.




Connecting from Storyboard to Source Code





Making a connection from a storyboard item to an existing outlet or action is similar to making a connection between two storyboard items. Select the storyboard item and control-drag to the outlet or action.





Xcode can also create outlets and actions by control-dragging from a storyboard item to a class in a source code file. When you are inside the class, Xcode’s editor will display the message Insert Outlet or Action. Release the button at that point. A popover like the following will open:
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Use the Connection menu to determine whether to create an outlet or an action. Enter a name in the Name text field. Use the Type combo box to specify the outlet’s data type or the type of the action’s sender. Use the Storage menu to determine whether to create a strong or weak reference for an outlet. Most outlets should be strong references. Click the Connect button to finish creating the outlet or action.













CHAPTER FOUR

Build the UI for the Notes Window







NOW THAT YOU’VE created the project, it’s time to create the first part of the app. Creating the user interface for the notes window is a good place to start. You’re going to need the following items in the notes window:






	A list of notes

	A text view to show and edit a note

	A container view that holds the list and the text view







Building the user interface for the notes window requires the following steps:






	Add a vertical split view controller to the storyboard

	Add a table view that holds the list of notes

	Add a text view that displays the selected note







A vertical split view controller positions the views side by side. That works best for NoteTaker, with the table view on the left and text view on the right.




Add a Vertical Split View Controller





Open the storyboard. Open the Object Library. Drag the Vertical Split View Controller item to the canvas. This creates a scene for the split view controller as well as two scenes for the view controllers in the split view controller.





Once you add the split view controller, you must get the window to show the split view controller instead of the view controller that came with the storyboard. Make a connection from the window controller to the split view controller to make the split view controller the view controller for the window’s content. It creates a relationship segue between the window controller and split view controller.





After adding the vertical split view controller, you can delete the original view controller from the storyboard. The vertical split view controller replaces the original view controller.







Adding a Table View to the First View Controller





When you added the split view controller, the two view controllers should be stacked vertically on the canvas. The top view controller’s contents appear on the left side of the split view. The bottom view controller’s contents appear on the right side of the split view. Drag the Table View item to the top view controller so it will appear on the left side of the split view.




Size the Table View





Split view controllers initially give each split view item the same width and height. The text view should be wider than the table view because it’s going to display more information than the table view. The text view should take two thirds to third fourths the width of the split view.





Make the table view fill the view vertically and have it fill about half of the content view. Shrink the content view of the table view controller so the content view has the same width as the table view. 




Configure the Table View as a Source List





Make the table view behave as a source list, similar to the sidebar that apps like Finder and Mail have on the left side of the window. Each item in the table view will display a note’s title.





Select the table view and open the attributes inspector. Make sure the following attributes are set for the table view:






	The content mode is view based.

	The number of columns is 1.

	The Headers checkbox is deselected.

	The highlight is source list.
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Resize the Table View When the Window Resizes





Select the table view’s scroll view and open the size inspector. Click the two arrows in the inner Autoresizing square to make the table view resize when the window resizes.
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Rename the Table View Controller





Select the view controller and open the attributes inspector. Change the title of the view controller to Table View Controller.




Connect the Data Source and Delegate Outlets





The last step is to connect the data source and delegate outlets. By connecting the outlets, the data source and delegate methods you write later in the book will get called properly.





Make a connection from the table view to the table view controller and select the dataSource outlet. Make the same connection a second time and select the delegate outlet.










Adding a Text View to the Second View Controller





Select the Rich Document Content Text View item from the Object Library and drag it to the bottom view controller. Older versions of Xcode will have a single Text View item in the Object Library. A rich text view will allow people to use multiple fonts, bold text, italic text, ordered lists, and unordered lists in their notes.





Resize the text view to fill the whole view inside the view controller.




Resize the Text View when the Window Resizes





Select the text view’s scroll view and open the size inspector. Click the two arrows in the inner Autoresizing square to make the text view resize when the window resizes.
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Rename the Text View Controller





Select the view controller and open the attributes inspector. Change the title of the view controller to Text View Controller.




Connect the Delegate Outlet





While you’re configuring the text view, you might as well connect the delegate outlet so the text view controller can handle events like the text changing.





Make a connection from the text view to the text view controller. Select the delegate outlet.










Change the Window Title





The initial title for the window is Window. If you want to change the window title, select the window. Open the attributes inspector.





Enter the title in the Title text field.
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View Controller Scenes





Each view controller scene in the storyboard is self-contained. If you try to make a connection from the table view controller scene to the text view controller scene, you’ll find you won’t be able to do so.





In the NoteTaker app when someone selects a note from the table view, that note’s contents should appear in the text view. Even though the table view controller and text view controller are part of the split view controller, you won’t be able to connect them in the storyboard. You’re going to have to write code to fill the text view when the table view’s selection changes. That code will come in Chapter 14: Notifications.










Run the Project





If you run the project, you should see the window appear. The table view will be empty. You can type in the text view. You can drag the splitter to adjust the width of the table view and text view. It may not look like you’ve done much, but you’re making progress. You can’t make an entire app in one step. You took the first step.





The next step in the project is to add user interface items so people can add and remove notes.













CHAPTER FIVE

Toolbars







THE USER INTERFACE for the NoteTaker app needs a way for people to add and delete notes. The easiest way for people to add and delete notes is to add a toolbar to the window and add toolbar buttons to add and delete notes. A toolbar appears at the top of a window and provides access to frequently used commands.





Adding a toolbar to a window isn’t too difficult. Start by adding a toolbar to the window. Add items to the toolbar.




Add Toolbar to Window





Drag the Toolbar item from the Object Library to the window inside the window controller scene. The toolbar must be a child of the window for the toolbar to show up in the window.




Add Buttons to the Toolbar





To add buttons to the toolbar, you must first open the toolbar. Click on the toolbar in the canvas or click on one of the default toolbar items in the document outline. You should see a sheet like the following:
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As you can see, the toolbar has two lists: allowed items and default items. The allowed items list has every item that can be in the toolbar. The default items list has the items that appear in the toolbar the first time someone launches the app. Unless the toolbar has many items, the allowed items and default items will be the same. People can customize the toolbar by control-clicking the toolbar and choosing Customize Toolbar.





Adding items to the toolbar takes two steps. First, add the items to the Allowed Toolbar Items list by dragging them from the Object Library to the allowed items list. Second, add the items to the toolbar by dragging them from the allowed items list to the default items list.





The NoteTaker app is going to have two buttons in the toolbar: one to add a note and one to delete a note. Open the Object Library and drag a textured rounded button to the Allowed Toolbar Items list. Repeat for the second button.





Drag the two buttons to the Default Toolbar Items list to add them to the toolbar. You can remove the Colors, Fonts, and Print items from the Allowed Toolbar Items list if you want. It won’t hurt if you keep them, but those items aren’t needed. Make sure the buttons are on the left side of the toolbar.




Edit the Toolbar Items





The two buttons you added to the toolbar have the title Textured Rounded and the palette label Custom View. The buttons need to be edited to indicate they’re used to add and delete notes. 





Select the first toolbar button from the Allowed Toolbar Items list and open the attributes inspector.
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Choose NSAddTemplate from the Image Name combo box. This will make the button have an image that looks like a plus sign to add an item. Enter the text Add Note in the Label and Palette Label text fields. The palette label appears under the toolbar item in the toolbar.





Now select the second toolbar item.
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Set the image name to NSRemoveTemplate. This will make the button have an image that looks like a minus sign to remove an item. Set the label and palette label to Delete Note. 




Edit the Button Titles





If you build and run the project, you’ll notice that setting an image for the toolbar items did not remove the Texture Rounded text from the button. You must set the title for each button to be blank.





Select the Add Note button from the document outline or jump bar and open the attributes inspector.
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Remove the text from the Title text field. Select the Delete Note button and remove any text from the Title text field. Now if you build and run the project, you will see the add and remove images in the toolbar buttons.




Custom View and Image Toolbar Items





Mac toolbar items can be either custom view or image items. Use a custom view toolbar item when you want to use an element from the Object Library, such as a button, in the toolbar. The buttons to add and delete notes are custom view toolbar items.





Use an image toolbar item when you want a custom icon for the toolbar item. An advantage of image toolbar items is they’re easier to enable and disable. 





If you look at the list of allowed toolbar items, the Colors, Fonts, and Print items are examples of image toolbar items. The Object Library has an Image Toolbar Item for you to add image toolbar items to the toolbar.





You could replace the toolbar buttons to add and delete notes with image toolbar items if you wanted. Drag two instances of the Image Toolbar Item from the Object Library to the list of allowed toolbar items. Use the attributes inspector to set the image names of the toolbar items to NSAddTemplate and NSRemoveTemplate.




Run the Project





Run the project and you should see the toolbar with the buttons to add and delete notes. Clicking the buttons won’t do anything, but remember you’re building one piece at a time. The user interface is coming together. Adding and removing the notes is coming later.




More Information





You can learn more about toolbars by looking at the following classes in Apple’s documentation:






	NSToolbar

	NSToolbarItem


















CHAPTER SIX

Menus







APPLE’S HUMAN INTERFACE Guidelines for Mac apps say that toolbar items need a corresponding menu item in case someone hides the toolbar. The NoteTaker app needs a Note menu in the menu bar with items to add and remove a note.




Add a Menu to the Menu Bar





You will notice that Xcode’s Object Library does not have a generic menu to add to a menu bar. Select one of the following menu items: Application, File, Edit, Font, Format, Text, Find, Window, or Help. I recommend the Help menu because it has the fewest menu items to remove later. Drag the menu item inside the Main Menu item in the Application scene.





Position the menu so it’s between the Window and Help menus. Change the name of the menu to Note. 




Add Items to the Menu





Select the Note menu in the canvas to see the items in the menu. Drag the Menu Item item from the Object Library to the Note menu. Remove any unneeded menu items. 





Double-click a menu item to change its title. Name the first item Add Note. Name the second item Delete Note.




Add Keyboard Equivalents





Keyboard equivalents let people make menu selections using the keyboard instead of a mouse. For many people pressing a couple of keys is faster than moving the mouse arrow to the menu bar and making a selection. People who have difficulty moving a mouse prefer having keyboard shortcuts for common commands.





What keyboard shortcuts should be used for the Add Note and Delete Note menu items? Let’s use the Cmd-N key combination as a shortcut to add a note. Normally the Cmd-N shortcut is used to create a new document, but the NoteTaker app does not create documents so we should use the Cmd-N shortcut to create a new note because people are used to pressing Cmd-N to create new items.





Let’s use the Delete (Backspace) key to delete notes. That’s an intuitive keyboard shortcut for deleting notes.




Set Keyboard Equivalent for the Add Note Menu Item





First, remove the New menu item from the File menu so the Cmd-N keyboard shortcut will work for adding notes. A keyboard equivalent cannot be used for multiple menu items.





Select the Add Note menu item, open the attributes inspector, and press Cmd-N inside the Key Equivalent text field.
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Set Keyboard Equivalent for the Delete Note Menu Item





Select the Delete Note menu item, open the attributes inspector, and press the Delete key inside the Key Equivalent text field.
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Responding to Menu Selections





To respond to a menu selection, create an action that gets called when someone selects the menu item. After creating the action, open the storyboard. Make a connection from the menu item to the First Responder object in the application scene. Choose the action you created from the list of actions.





Read Chapters 11 and 13 for more information on responding to menu selections.




Why Are My Menu Items Disabled?





If you launch your app and find the menu items disabled, the most likely reason is the menu items are not connected to an action. Run the NoteTaker project right now and you’ll find the menu items to add and delete notes are disabled. They’re disabled because you haven’t written the actions to add and delete the notes and haven’t connected the menu items to anything.





Be patient. Later on in the book you will be writing the actions and connecting the menu items to the actions. You’ve finished building the user interface for the app. Be happy about that.




More Information





You can learn more about menus by looking at the following classes in Apple’s documentation:






	NSMenu

	NSMenuItem


















CHAPTER SEVEN

View Controllers







VIEW CONTROLLERS CONTROL views. The NoteTaker app has three view controllers: one for the table view, one for the text view, and one for the split view that contains the table view and text view.





In this chapter you’re going to create subclasses for the view controllers you created in the storyboard so you can access the user interface elements in your code. And you’re going to learn the basics of using view controllers in Mac apps.







Create the Split View Controller Subclass





Creating subclasses involves adding new files to your project. Choose File > New > File to add a new file to your project. The New File Assistant opens. Select macOS at the top of the New File Assistant to see the Mac file templates. Select the Cocoa Class file template. Click the Next button.




[image: ]





Enter the name of the class in the Class text field. I used the name SplitViewController. 





Make the new class a subclass of NSSplitViewController.





Deselect the checkbox to create a xib file. The split view controller is already in the storyboard so you don’t need a new xib file for the controller.





Choose Swift from the Language menu. Click the Next button. 





Choose a location to save the file. Click the Create button to finish creating the class.




Set the Split View Controller’s Class in the Storyboard





After creating the split view controller subclass, you must set the class of the split view controller in the storyboard to the subclass you created. If you don’t set the class, the storyboard will treat your split view controller as a generic split view controller instead of an object of your subclass. Open the storyboard, select the Split View Controller item, and open the identity inspector.




[image: ]





Set the class to the name of the subclass you created.










Create the Table View Controller Subclass





Now it’s time to create a subclass for the table view controller. The steps are similar to creating the split view controller subclass. Choose File > New > File. Select Cocoa Class from the list of Mac file templates. Click the Next button.




[image: ]


Enter the name of the class in the Class text field. Make the class a subclass of NSViewController. There is no Mac equivalent of the UITableViewController class on iOS. Don’t create a xib file. Choose Swift from the Language menu. Click the Next button.





Choose a location to save the file on your Mac. Click the Create button to finish creating the file.




Set the Table View Controller’s Subclass in the Storyboard





Now it’s time to open the storyboard and set the class of the table view controller. Select the Table View Controller item from the storyboard and open the identity inspector.
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Set the class to the subclass you created.




Create an Outlet for the Table View





The table view controller has one additional step you didn’t have to perform on the split view controller: creating an outlet, specifically an outlet for the table view. Creating an outlet lets you access the table view in code.





Open the assistant editor in Xcode so the storyboard and table view controller subclass file are both open.





Make a connection from the table view in the storyboard. Hold down the Control key, and drag to the source code file. When you are inside the class, Xcode’s editor will display the message Insert Outlet or Action. Release the button. A popover like the following will open:




[image: ]





Enter a name for the table view outlet. Make the type NSTableView, which is the class for Mac table views. Choose Strong from the Storage menu. Click the Connect menu to create and connect the outlet. The following screenshot shows how an outlet looks in code:




[image: ]





The filled-in circle on the left side of the editor indicates the outlet is connected.










Create the Text View Controller Subclass





The last subclass to create is the text view controller. The steps are exactly the same as they are for creating the table view controller subclass. The only difference is the name of the subclass.




Set the Text View Controller’s Subclass in the Storyboard





Open the storyboard. Select the Text View Controller item from the storyboard and open the identity inspector.
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Set the class to the subclass you created.




Create an Outlet for the Text View





The last step is to create an outlet for the text view so you can access it in your code. The steps are very similar to creating an outlet for the table view. Make sure both the storyboard and text view controller subclass file are both open. Make a connection from the text view in the storyboard. Control-drag to the source code file.
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Make sure the type is NSTextView, which is the class name for text views. Click the Connect button to finish creating the connection.
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View Controller Hierarchy





Each view controller has a children property that contains an array of view controllers. In the SplitViewController class, you can use that property to access the table view controller and text view controller with computed properties.





var tableViewController: TableViewController? {
    return children.first as? TableViewController
}

var textViewController: TextViewController? {
    return children[1] as? TextViewController
}






Notice that the table view controller is the first element in the children array and the text view controller is the second element.





Each view controller has a parent property. In the TableViewController and TextViewController classes, you can use the parent property to access the split view controller with computed properties.





var splitViewController: SplitViewController? {
    return parent as? SplitViewController
}






You can also use an if-let statement to access the split view controller.





if let splitViewController = parent as? SplitViewController {

}








viewDidLoad





If you look at the Swift files for the view controller subclasses you created, you should see the following function in each of the subclasses:





override func viewDidLoad() {
    super.viewDidLoad()
    // Do view setup here.
}






The function is viewDidLoad. It gets called when the view finishes loading. Use the viewDidLoad function to do any setup code for the view controller.





In the final version of NoteTaker the viewDidLoad method in the split view controller calls a function to load the notes from disk. Loading the notes is something you want to do at initialization time so the table view shows the notes when the app finishes launching.










Storyboard Segues





A storyboard segue is a transition from one view controller or window controller to another. If you’ve done any iOS programming, you know that segues are used a lot in iOS apps to move from one screen to another.





On the Mac storyboard segues are primarily used to show views and windows. An example of a segue is the popover that opens in Xcode to create an outlet or action when you make a connection from a user interface element to a source code file. Other examples of Mac storyboard segues include showing preference windows and showing previews. 





There are no segues in NoteTaker because there is only one window to display. The material in this section is for people who are curious about segues.




Adding a Segue





To add a segue make a connection from one view controller to another in the storyboard. A panel with a list of segue types appears. Select a segue. Mac storyboards have the following segue types:






	Show

	Popover

	Sheet

	Modal

	Embed

	Custom







The show segue shows a window and works with window controllers. The popover segue displays a popover. Think Xcode’s popovers for creating outlets and actions.





The sheet segue shows a sheet inside the current window. The modal segue shows a modal window, such as an alert or a dialog box.





The embed segue embeds the destination controller inside the source controller. The custom segue lets you create your custom method for presenting a controller.





You can give the segue a unique identifier by selecting it from the document outline or jump bar and opening the attributes inspector.




The prepareForSegue Method





If you need to pass data to the controller being presented, override the function prepareForSegue.





override func prepare(for segue: NSStoryboardSegue, sender: Any?) {

}






The segue argument is the segue you’re about to perform. The sender argument is the object that initiated the segue.










More Information





You can learn more about view controllers by looking at the following classes in Apple’s documentation:






	NSViewController

	NSSplitViewController


















CHAPTER EIGHT

Build the Data Model







THE NEXT STEP in creating Note Taker is to create a data model to store notes. The data model for NoteTaker is simple. Create a struct for notes.




The Note Struct





Start by adding a new file to the project. Choose File > New > File to create a new file. Choose Swift File from the list of Mac source file templates. Because you’re using a struct to store notes, you don’t need to create a Cocoa class like you had to with the view controller subclasses. Click the Next button. Name the file. I named it Note. Click the Create button to finish creating the file.





Declare a struct for the notes by adding the following code to the Note.Swift file:





struct Note {
    var title: String = ""
    var contents: NSMutableAttributedString = 
        NSMutableAttributedString(string: "")
}



A note has a title and contents. The contents have the data type NSMutableAttributedString because the notes are in rich text. Attributed strings allow rich text so the notes can have things like multiple fonts, bold text, and unordered lists. The attributed string must be mutable for people to write notes and change their contents. If you were writing a plain text note taking app, you could store the contents as a Swift string.







Storing the Notes





The NoteTaker app contains a list of notes. How do you store the notes? Create an array of the Note struct.





var notes = [Note]()






Creating the array for the notes is the easy part. The more difficult part is figuring out where to store the notes array.





For the NoteTaker app I chose to store the array in the split view controller. The split view represents the whole collection of notes. Plus, having the array in the split view controller makes it easier for the table view and text view to access the notes because the split view controller is the parent of the other two view controllers.




Architecture





NoteTaker is a simple app so I can get away with storing the array of notes in the split view controller. But a more complex app requires a better architecture. Stick everything in the view controller and you end up with something iOS developers call massive view controller. I want to focus on Mac development, not software architecture in this book. But I’m letting you know that my choice for NoteTaker is not a great choice for more complex apps.





If NoteTaker were more complex, I would create a NotesController class or struct that contained the notes array. The split view controller would have a property for the notes controller and use that to access the notes array.
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CHAPTER THIRTEEN

Deleting Notes







AFTER ADDING NOTES the next feature to add is deleting notes. The programming steps for deleting notes are similar to the steps for adding notes. Create an action to delete notes, remove the selected note from the notes array, and refresh the table view. There is one additional step to perform. You must select a new chapter to replace the deleted chapter.




Add an Action





You must create an action that gets called when someone clicks the Delete Note button in the toolbar or chooses Note > Delete Note.





Open the split view controller’s Swift file and add the following code:





@IBAction func deleteNote(_ sender: AnyObject) {

}





Deleting a Note





Deleting a note involves the following steps:






	Get the table view’s selected row.

	Remove the selected note from the list of notes.

	Refresh the table view so the deleted note is not in the list.







Here’s the code to delete the note.





@IBAction func deleteNote(_ sender: AnyObject) {
    guard let row = tableViewController?.tableView.
        selectedRow else {
            return
    }
    notes.remove(at: row)
    tableViewController?.tableView.reloadData()
}






The guard statement handles the case of no row being selected in the table view. If there is no selected row, do nothing.




Select a Different Note





Because the selected note has been deleted, you must select a new note. For NoteTaker I chose to select the note that was above the deleted note. The first step is to get the index of the new selection. Add the following code to the end of the deleteNote action:





let newSelectionIndex: Int
if row > 0 {
    newSelectionIndex = row - 1
}
else {
    // Select the first item if
    // we deleted the first note
    // in the table.
    newSelectionIndex = row
}






After getting the selection index, select that item in the table view. Add the following function to the table view controller:





func selectNote(_ position: Int) {
    let indexSet = IndexSet(integer: position)
    tableView?.selectRowIndexes(indexSet, 
        byExtendingSelection: false)
}






To select a row you have to create an IndexSet object because the function that selects rows in a table view, selectRowIndexes, takes an IndexSet as an argument. NoteTaker supports selecting only one note at a time so the byExtendingSelection argument should be false.





In the deleteNote action, make the call to selectNote, passing the new selection index.





tableViewController?
    .selectNote(newSelectionIndex)





Connect the Action to the User Interface





The final step is to connect the action to the Delete Note button and the Delete Note menu item so the action is called when clicking the button or choosing the menu item. Let’s start with the button in the toolbar.





Open the storyboard and expand the window controller scene in the document outline. Make a connection from the Delete Note toolbar item to the First Responder object in the window controller scene. A HUD panel with a long list of actions open. Select the deleteNote action from the list.





Connecting the Delete Note menu item is similar. Expand the application scene in the document outline. Make a connection from the Delete Note menu item to the First Responder object in the application scene. Choose deleteNote from the long list of actions.




Run the Project





If you build and run the project, you should be able to delete notes. You should be able to delete them in three ways: clicking the Delete Note button in the toolbar, choosing Note > Delete Note, or by selecting a note in the table view and pressing the Delete (Backspace) key.
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CHAPTER FIFTEEN

Saving and Loading Files







IF YOU HAVE been running the NoteTaker app, you noticed one big flaw in the app so far. Every time you launch the program, there are no notes in the table view. You’re going to fix that in this chapter. You’re going to learn how to save the notes to a file and load them when the app launches.





Saving and loading files in NoteTaker is going to be more difficult because NoteTaker is not a document-based app and does not use Core Data. The NSDocument class and Core Data have functions to make saving and loading files easier. But NoteTaker doesn’t make sense as a document-based app, and Core Data is a complex topic worthy of its own book.





To keep this chapter from being a massive code dump, the code listings in this chapter show enough code to demonstrate the concept being explained. I have complete code listings in the GitHub project. Look at the files FileSavingAndOpening.swift and Note.swift.




Converting Notes to Data Objects





Before you can save files, you need to write code to convert a note to a Data struct. The Foundation framework, which is part of the Cocoa framework, uses the Data struct to create buffers of data that can be efficiently saved and loaded. The functions in Apple’s frameworks to write files take an argument of type Data. But Apple makes it relatively easy to convert rich text to type Data.





The NSMutableAttributedString class has a rtf method that takes the range of an attributed string and returns an optional Data object. Add the following function to the Note struct to convert the note’s contents to a Data object:





func write() -> Data? {
    let range = NSRange(location: 0, length: contents.length)
    return contents.rtf(from: range)
}






The first line of code calculates the range of the note. That range is passed to the rtf function.




Converting Data Objects to Notes





When loading notes you’re going to get Data objects. The Data objects contain attributed strings. You must convert the Data objects to attributed strings and set the note’s contents to that attributed string.





Unfortunately you can’t go directly from a Data object to a mutable attributed string. You have to do the conversion through an attributed string.





The NSAttributedString class has an initializer that takes a Data object as an argument. The NSMutableAttributedString class has an initializer that takes an attributed string as an argument. Add the following function to the Note struct to fill a note’s contents from a Data object:





mutating func read(data: Data?) {
    guard data != nil else {
    return
    }
    // The guard ensures the data is not nil 
    // so I can force unwrap.
    if let fileContents = NSAttributedString(rtf: data!, 
        documentAttributes: nil) {

        contents = NSMutableAttributedString(
            attributedString: fileContents)
    }
}






The mutating keyword is required because the read function changes the value of the Note struct’s contents property. The guard statement makes sure there is data to read.





The read function would be easier to write if the argument was a Data object instead of an optional, but creating an empty Data object if file loading fails and passing it to the read function is more painful than making the argument an optional value.










Choosing a Location to Save Notes





If NoteTaker was a document-based app, the person using it would choose File > Save and choose a location to save the file. But you have to pick a place to save the notes for NoteTaker because it isn’t a document-based app and there’s no Save panel to open.





A standard location for saving files is in the Application Support folder. Create a folder for the app and store the notes there.




Locating the Application Support Folder





Use the FileManager class to locate the Application Support folder. Start by getting the default file manager.





let fileManager = FileManager.default






Call the FileManager url method to get the URL to the Application Support folder. The url method takes the following arguments:






	The search path directory. Use the value .applicationSupportDirectory for the Application Support folder.

	The file system domain to search. Use the value .userDomainMask to search in the user account domain.

	Appropriate for, which you can pass nil.

	Should the directory be created if it doesn’t exist? Pass the value true.







The url method can throw an exception so you must wrap it in a do-catch block.





do {
    let userApplicationSupportFolder = try fileManager.url(
    for: .applicationSupportDirectory,
    in: .userDomainMask, 
        appropriateFor: nil, create: true)
} catch {
    print("Failed")
}





Adding the App Name Folder





Now we need to add a folder with the app name to the Application Support folder. The first step is to append a path component to the URL for the Application Support folder. The URL class has an appendingPathComponent function for adding path components to URLs.





let noteFileLocation = userApplicationSupportFolder.
    appendingPathComponent("NoteTaker")






Call the FileManager method createDirectory to create the directory. The createDirectory method takes the following arguments:






	The location to create the directory, which is the URL for the Application Support folder with the app name component added to it.

	Should any intermediate directories be created if needed? Pass the value true.

	File attributes. You can pass nil.







The createDirectory method can throw an exception so you must wrap the call in a do-catch block.





do {
    try fileManager.createDirectory(at: noteFileLocation,       withIntermediateDirectories: true, 
        attributes: nil)
} catch {
    print("Failed")
}






Refer to the noteFileLocation method in the FileSavingAndOpening.swift file in the GitHub project for the full code to get the location to save notes.










Saving Files





Ideally we could convert the notes array into a Data object and save that to a file. But the code would be messy and tough to explain.





If there was only one note to save, you could use the FileManager method createFile to create the file. The createFile method takes the following arguments:






	A path for the new file. You could call the URL method appendingPathComponent to add a file name.

	The contents to save, which is a Data object.

	An optional dictionary of attributes.







Many Mac apps can use createFile to create and save files.




Saving with File Wrappers





NoteTaker has multiple notes to save most of the time. You could call createFile for each note, but there’s a better way to save all of the notes in one location. 





Use a file wrapper to save the notes. A file wrapper is a collection of directories and files grouped together.




File Wrapper Structure 





The file wrapper structure to save the notes in NoteTaker is the following:






	A root directory

	A Notes folder inside the root directory

	A file for each note






Creating a Directory File Wrapper





To create a directory file wrapper, call the FileWrapper class initializer with the directoryWithFileWrappers argument. The following code creates an empty directory for the root directory:





let mainDirectory = FileWrapper(directoryWithFileWrappers: [:])






Setting the preferredFilename property gives the file wrapper a name. The root directory does not appear in the Finder so you don’t need to give it a name. The following code creates the Notes folder:





let notesDirectory = FileWrapper(directoryWithFileWrappers: [:])
notesDirectory.preferredFilename = "Notes"





Adding Children to a File Wrapper





The Notes folder should appear inside the root directory. Call the addFileWrapper method to add a child file wrapper.





mainDirectory.addFileWrapper(notesDirectory)





Creating a File Wrapper for a File





Creating a file wrapper is similar to creating one for a directory. Call the FileWrapper class initializer with the regularFileWithContents argument. Supply a Data object. If you remember earlier in the chapter, we created a write function to convert a note to a Data object. We’re going to use that function to create a file for the note. After creating the file for the note, add it as a child of the Notes folder. The following code shows the initial structure for creating files for the notes and adding them to the Notes folder:





for note in notes {
    if let noteData = note.write() {
    let wrapper = FileWrapper(
            regularFileWithContents: noteData)
        notesDirectory.addFileWrapper(wrapper)
   }
}





Naming the Files





One thing missing from the code in the previous section is naming the file. We can use the note’s title as the name of the file. But there’s a potential problem. What happens if two notes have the same title?





We should append a unique identifier to the title and use that as the name of the file. What I did for NoteTaker is to append the string -00 to the title, and then append the note’s position in the list. So the first note has -000 appended to the title, the second note has -001, the third note has -002, and so on. The following code builds the file name for a note file:





func buildFilename(note: Note, position: Int) -> String {
    var filename: String = ""
    filename += note.title
    filename += "-00"
    filename += String(position)
    return filename
}






To build the file names for the notes properly, we need a variable to store the current position that we pass to buildFilename. The following expanded code creates files for each note:





var index = 0
for note in notes {
    if let noteData = note.write() {
    let wrapper = FileWrapper(
            regularFileWithContents: noteData)
        let filename = buildFilename(note: note, position: index)
        wrapper.preferredFilename = filename
        notesDirectory.addFileWrapper(wrapper)
   }
    index += 1
}





Writing the File Wrapper to Disk





Call the FileWrapper method write to write the wrapper to disk. Supply the following arguments:






	The location to write the file.

	Optional options, which are .atomic and .withNameUpdating. Atomic writing ensures the file wrapper is never in an inconsistent state.

	The location of the original contents. If you pass nil, the entire file wrapper is written to disk, which can cause unnecessary file writing if the contents of a file did not change.







The location to write the file and the location of the original contents can be the same. The write method can throw so you must wrap it in a do-catch block.





if let saveLocation = noteFileLocation() {
    // Write the file wrapper to the URL
    do {
        try wrapper.write(to: saveLocation, options: .atomic, 
            originalContentsURL: saveLocation)
    } catch {
        print(error)
    }
}





Run the Project





Run the project and create some notes. Quit the app and navigate to the Application Support folder in the Finder on your Mac. It is at the following path:





/Users/YourUsername/
Library/ApplicationSupport






If you don’t see a Library folder, perform the following steps on your Mac:






	Go to your user folder in the Finder.

	Choose View > Show View Options.

	Select the Show Library Folder checkbox.







You should see a NoteTaker folder in the Application Support folder. There should be a Notes folder inside the NoteTaker folder. There should be a text file for each note in the Notes folder. Double-clicking a file will open it in TextEdit.










Loading Files





Now it’s time to load the notes you saved. Loading the files requires the following steps:






	Load the file wrapper containing the notes

	Find the Notes folder in the file wrapper

	Access each note’s file

	Read the note from the file






Loading the File Wrapper





The first step is to load the root directory of the file wrapper holding the notes. Call the FileWrapper class initializer that takes a URL and reading options as arguments. You’re going to use the code from earlier in the chapter to get to the app’s folder in the Application Support folder and pass that URL to the initializer. This initializer throws exceptions so you must wrap it in a do-catch block.





guard let noteLocation = noteFileLocation() else {
    return
}

do {
    let mainDirectory = try FileWrapper(url: noteLocation, 
        options: .immediate)
} catch {
    print(error)
}






Using the .immediate reading option ensures that the content of the file wrapper is read immediately. You’re going to load the notes when the app launches so the notes should be read immediately.




Finding the Notes Directory





The root directory contains a dictionary of file wrappers. Supply the key of the directory or file you want to find as a subscript. The following code gets the Notes folder from the root directory:





if let notesDirectory = mainDirectory.
    fileWrappers?["Notes"] {

}





Accessing the Note Files





Use the fileWrappers property to access the children of a file wrapper. The following code accesses the note files from the Notes folder:





if let noteFiles = notesDirectory.fileWrappers {

}





Reading a Note





Use the filename property to get a file wrapper’s file name. The start of the file name contains the note’s title.





Use the regularFileContents property in the FileWrapper class to read the note’s contents from disk. The file contents are a Data object. Call the Note struct’s read function to read the contents from the Data object. After reading the note from disk, add it to the notes array.





func readNote(noteFile: FileWrapper) {
    if let filename = noteFile.filename {
    // Get the note title from the file name.
        let fileComponents = filename.components(
            separatedBy: "-00")
        var newNote = Note(title: "Note", contents:             NSMutableAttributedString(string: ""))
        newNote.title = fileComponents.first ?? "Note"

        // Load the note contents.
        let emptyString = ""
        newNote.read(data: noteFile.regularFileContents ??          emptyString.data(using: .utf8))
        notes.append(newNote)
    }   
}






The first part of the code inside the if-let block reads the note title using the note’s file name. Everything before the -00 in the file name is the note’s title. The second part of the code reads the note contents and adds the note to the notes array.




Run the Project





Run the project. Add some notes. Quit the app. Run it again. The notes you created should appear in the table view. You can now use NoteTaker as a real note-taking app. This is a big milestone.










More Information





You can learn more about saving and loading files by looking at the following classes and structs in Apple’s documentation:






	FileManager

	FileWrapper

	URL

	Data
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CHAPTER SEVENTEEN

Undo







YOU CURRENTLY HAVE a working app, but there are improvements to make. One big improvement you can make in NoteTaker is to let people undo if they accidentally delete a note.




Accessing the Undo Manager





Shoebox apps (apps that are not document-based) have an undo manager for the entire app, which you can access with the undoManager property.




Registering Undo Actions





Call the undo manager’s registerUndo function to register an undo action. Supply a target and a closure that is called when someone chooses Edit > Undo.





The undo action is a function that does the opposite of the original action you want to undo. In the NoteTaker app when someone chooses Edit > Undo after deleting a note, the deleted note should be restored. The undo action will be a function that restores a deleted note. Add the following code before the line of code that removes the note from the notes array:





let noteToDelete = notes[row]
undoManager?.registerUndo(withTarget: self, 
    handler: { targetSelf in

    targetSelf.restoreNote(noteToDelete, location: row)
})






The code looks complicated, but all it does is call a function called restoreNote that takes a note and a location as arguments.




Setting an Action Name





An action name is the text that gets appended to the Undo item in the Edit menu. Call the undo manager’s setActionName function and supply the text. Add the following code after the call to registerUndo to make the Undo menu item text Undo Delete Note when someone deletes a note:





undoManager?.setActionName("Delete Note")





Restoring the Notes





Now it’s time to write the function to restore the notes.





func restoreNote(_ deletedNote: Note, location: Int) {
    // Register the redo action with the undo manager.
    undoManager?.registerUndo(withTarget: self) { targetSelf in
    targetSelf.deleteNote(self)
    }
    undoManager?.setActionName("Delete Note")

    notes.insert(deletedNote, at: location)
    tableViewController?.tableView.reloadData()
    tableViewController?.selectNote(location)
}






The code starts by registering the redo action. The redo action is to delete the note, hence the call to deleteNote when registering the redo action. Because it’s a redo action, the action name is Delete Note, not Restore Note. The menu item is going to be Redo Delete Note.





The last three lines of code insert the deleted note back at its old location, reloads the table view, and selects the deleted note.




Run the Project





Run the project. Delete a note. Choose Edit > Undo Delete Note. The deleted note should return when you choose to undo. Now the NoteTaker app is safer. People can restore a note if they accidentally delete it.
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